サーバいじくり雑記

2014年7月17日

UPDATING 20140714 AFFECTS: users of databases/db6

Filed under: FreeBSD — bompopo @ 7:35 AM
20140714:
  AFFECTS: users of databases/db6
  AUTHOR:  mandree@FreeBSD.org

  Oracle Berkeley DB 6 has been upgraded to version 6.1.19.  Since the
  previous 6.0 version, the log file format has changed in 6.1.
  Depending on applications used, you may need to take action BEFORE you
  upgrade.  For details, please see the online upgrade manual at
  <http://docs.oracle.com/cd/E17076_04/html/upgrading/upgrade_process.html>
  <http://docs.oracle.com/cd/E17076_04/html/installation/upgrade_61_toc.html>

  Note: if you've got Apache installed and depending on db6, you may
  need to upgrade it separately BEFORE upgrading other ports.

  Note: some GNOME-related ports, for instance, evolution-data-server,
  cannot be built if their older version is installed because they run
  their own executables at build-time and prefer libraries from
  $LOCALPATH over freshly-built ones.  For these ports, deinstall
  them with pkg_delete -f or pkg delete -f before trying to upgrade them.

  After that, you must rebuild all applications that link to db6 because
  the shared library name has changed with the upgrade.  To do that:

  If you use portmaster:
        portmaster -w -r db6-
  If you use portupgrade:
        portupgrade -fr databases/db6
広告

コメントする »

まだコメントはありません。

RSS feed for comments on this post. TrackBack URI

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。