サーバいじくり雑記

2014年6月27日

インターネットはIEの最新バージョンでセキュアに、 業務システムはIE8互換ブラウザthinforieでこれまでどおり!

Filed under: セキュリティ, ソフト, Windows — bompopo @ 10:34 AM

インターネットはIEの最新バージョンでセキュアに、 業務システムはIE8互換ブラウザthinforieでこれまでどおり!

最新コンポーネントの互換モードでもIE6を再現できないものがある…。というか沢山。

IE6アプリケーションの画面と操作性をそのまま実現するthinforie、本物のIE6とは何が違うのでしょうか。
答えはコンポーネントです。
thinforieには、ライセンスに抵触するIE6のコンポーネントは一切含まれていません。物理OSにインストールされたIEコンポーネントを利用します。
一方で、UserAgentはIE6と同じものを用いることにより、ユーザー側にはIE6アプリケーションと同等の操作感を提供しています。

もしかしてさ、MS純正IE6のコンポーネントを独立した場所に入れ独立したレジストリで管理して、この製品はそれを呼び出しているだけって気もするんだけど…。だとしたらセキュリティ面はまったく解決しない。。。
手に入れて確かめようにも評価版ダウンロードも出来なさそうだし。

広告

コメントする »

まだコメントはありません。

RSS feed for comments on this post. TrackBack URI

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。