サーバいじくり雑記

2013年12月18日

UPDATING 20131217 AFFECTS: users of databases/ruby-bdb or ports-mgmt/portupgrade and databases/db5 or databases/db6

Filed under: FreeBSD — bompopo @ 8:32 AM
20131217:
  AFFECTS: users of databases/ruby-bdb or ports-mgmt/portupgrade and databases/db5 or databases/db6
  AUTHOR: mandree@FreeBSD.org

  databases/db5 and databases/db6 have recently been updated to fix
  bugs. This changed their patchlevel version.

  However, ruby-bdb breaks during the upgrade due to a bug described in
  <http://www.freebsd.org/cgi/query-pr.cgi?pr=184921>.

  THIS MEANS THAT YOU MUST NOT USE PORTUPGRADE TO UPGRADE databases/db5
  databases/db6 and databases/ruby-bdb. Doing that will break the latter and
  cause corrupted dependency data.  Use portmaster for the upgrade.

  If you are in a situation where portupgrade refuses to work with
  errors like:

  DB needs compatible versions of libdb & db.h
    you have db.h version 5.3.21 and libdb version 5.3.28

  then you must manually upgrade the ruby-bdb port and repair dependency data:

  # make -C /usr/ports/databases/ruby-bdb all deinstall install clean
  # pkgdb -fu
  # portupgrade -f db5 db6

  This should return portupgrade to normal operation.
広告

コメントする »

まだコメントはありません。

RSS feed for comments on this post. TrackBack URI

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。